menü    videók      
Mit tanulnál?
Keresés:
videót kérek belépés regisztráció
 Termék tesztek, hírek, bemutatók  ✦  mobilok, okosórák, médialejátszók, stb.  ✦  kattints ide!
Android (Flutter) fejlesztés, 1. rész - a fejlesztési környezet telepítése (2019.09.15)
Bejegyzések a témában:   flutter   android  
Hozzászólások
"A Flutter a Google felhasználói felületének eszközkészlete, amely egyetlen kódbázisból készíti a gyönyörű, natív alkalmazásokat mobil, web és asztali számítógépekre." Ebbe beleértendő az Android és az iOS is.

Ebben a sorozatban megismerkedünk vele, viszont a programozás alapjairól nem lesz, de ahhoz itt találhatók videók.

Az első lépés a Flutter SDK beszerzése itt. Ez egy szimpla zip fájl, amit csak ki kell tömöríteni (de lehetőleg ne a program files vagy hasonló mappába, mert az magasabb jogosultságot kíván és problémát okozhat a használatában).

A következő a környezeti változó beállítása, amely a start menübe begépelve elvégezhető: körny




majd "Környezeti változók..."

A felhasználói változó részben "Path"  > Szerkesztés és egy új elérést hozzá kell adni, ami a Flutter telepítési mappáján belül a bin mappa, vagyis ilyesmi:

c:programokprogramozasFlutterbin

Majd OK és megint OK.

Ha a Path nem létezik, akkor létre kell hozni.

Ezt követően parancssort vagy Powershell-t nyitva a program mappájában állva ki kell adni a flutter doctor parancsot, amely közli a problémákat.



Mint látható, még nincs az Android SDK és az Android Studio sem telepítve.

Az SDK mint látható innen beszerezhető:  https://developer.android.com/studio/index.html

Valójában az Android Studio-val együtt érkezik:



Telepítsük tehát az Android Studio-t, amit ha még nem ismersz, akkor érdemes a telepítés során mindent hagyni, ahogy van (kivétel az adatok küldését a Google-nek, az kihagyható).

Ha kész, akkor megint flutter doctor, ami vélhetőleg további problémákat talál:



A flutter doctor --android-licenses paranccsal elfogadhatjuk az Android licenceket (minden kérdésre y).

Majd az Android Studio-t elindítva alul van a Configure > Plugins:



A flutter és a dart plugin telepítése szükséges, de a flutter telepítéséhez szükséges a dart is, amelyet megold önmagától. Ha kész, akkor indítsuk újra az Android Studio-t (restart IDE).

A flutter doctor parancsot kiadva már csak egy probléma marad, ami a következő rész témája lesz.